Running Juce Demo changes my mouse acceleration


#1

I am using a Logitech gaming mouse with 3 acceleration settings adjustable on the mouse with some buttons.

When I run Juce Demo, the acceleration for my mouse changes. Exiting the demo does not restore the acceleration to the user defined value. I must change the acceleration using the buttons on the mouse, then change it back, to get my original acceleration setting.

Note that when Juce causes the acceleration to change, there is no feedback on the mouse. I doubt this is an issue with the mouse.

I have these defines in my AppConfig:

//#define JUCE_FORCE_DEBUG
//#define JUCE_LOG_ASSERTIONS
//#define JUCE_ASIO
#define JUCE_WASAPI 1
//#define JUCE_DIRECTSOUND
//#define JUCE_ALSA
#define JUCE_QUICKTIME 0
#define JUCE_OPENGL 1
//#define JUCE_USE_FLAC
//#define JUCE_USE_OGGVORBIS
//#define JUCE_USE_CDBURNER
//#define JUCE_USE_CDREADER
//#define JUCE_USE_CAMERA 1
//#define JUCE_ENABLE_REPAINT_DEBUGGING
//#define JUCE_USE_XINERAMA
//#define JUCE_USE_XSHM
//#define JUCE_USE_XRENDER
//#define JUCE_USE_XCURSOR
#define JUCE_PLUGINHOST_VST 0
#define JUCE_PLUGINHOST_AU 0
//#define JUCE_ONLY_BUILD_CORE_LIBRARY
#define JUCE_WEB_BROWSER 1
//#define JUCE_SUPPORT_CARBON
//#define JUCE_CHECK_MEMORY_LEAKS
//#define JUCE_CATCH_UNHANDLED_EXCEPTIONS

I have noticed that this also happens every time I run Fallout: New Vegas. So perhaps this is DirectInput related?


#2

There’s absolutely nothing that I can think of that juce does which would make any difference at all to settings like that! It must be a decision that the mouse driver is making, perhaps because the demo uses an openGL window, the mouse driver assumes you’re playing a game and turns off acceleration!?


#3

I have the Logitech Desktop Software installed for my mouse. There’s an option “Enable Game Detection” which was turned on. When a game is launched the mouse acceleration changes. Apparently, Logitech thinks that a JUCE application is a game. Perhaps related to DirectInput or something similar.

Anyway, turning off this “Game Detection” feature solved the problem so this issue is closed.