Scale/size issue with plugin window (very very small) from Plugin Host example


#1

I am getting ultra-small plugin editor windows on windows 10. Too small to even work with.

Note that this is occurring with any plugin who’s editor window is summoned from the included JUCE “Plugin Host” example.

Something is not being set there, have seen some articles talking about “getDesktopScaleFactor” but modifying this value does not help. The plugin editor window can not be resized manually, because I think it is missing a “ResizableCornerComponent.”

Would greatly appreciate a thought or pointer as to where one might troubleshoot this. Have spent a fair amount of time reading posts and looking through source, but this is proving very difficult to isolate.

(I believe this is windows 10 specific, because I have seen on different machines over time that resizing or adjusting font settings on 10 can cause applications to scale oddly. Perhaps something to do with DPI, I am not certain. )


#2

Just so that I can try to reproduce this, what DPI scaling factor are you using in Windows 10? Are you on a HiDPI display?


#3

+1

Related:


#4

Yes, this is the same issue as in my post that OBO links to.
@fabian, I tested with a retina iMac running windows 10. When running the native resolution of the screen (5120 x 2880) The windows 10 scale settings has to be at 200% to make it look normal.


#5

I would add that this only occurs on a high-end Gaming laptop, other windows 10 devices (Desktops, 3 of them I have tried) do not have this problem. And this is definitely a super-high resolution screen. So it is very likely a scale-related issue as described. Are there any suggestions as to a code-related workaround? Am happy to experiment, but not entirely sure where in the JUCE source responsibility lies.


#6

any more hints on the strategy for HiDPI in Windows Plugins? How do you currently solve it?


#7

Sorry it’s taking so long. We are still working on fixing this.


#8

Moved to all 4K monitors here and now it’s getting increasingly difficult to ignore the HIDPI woes reported by users :wink:

Windows 10 scaling factor is 1.75 or 2.0. The plugin window (derived from the plugin host example) opens at the right size (scaled), but the plugin’s editor in it shows up at 1:1 pixels, which is extremely tiny. Rest of the window is left blank (black).

Any update on this?


#9

This hasn’t been forgotten and we are running into scaling issues ourselves at ROLI so this is quite hight up on our list. We’ll update this post when the scaling fixes are ready.


#10

Just checking @fabian has this been resolved?
Just checking if something happen here that I missed


#11

Please check develop. I think this has been resolved now by jules recently.


#12

Thanks, as far as I can see, there is one commit that seems related. Adding some scaling options. But this does not work for me.
I think this is the other way around, where a Juce plugin can be scaled by a host.
I’m talking about the issue where none-juce plugins get super small on windows 10 with hi dpi screens when hosted in a juce host.


#13

This is definitely resolved for a juce plugin in a juce host - I did it a couple of weeks ago. Both sides need to be rebuilt of course.


#14

Yes, that works super, problem is none-juce plugins in juce host.
I’m not sure if it is even possible to fix from our/your side.
“My” problem is that there are 100.000.000 none-juce plugins out there that don’t scale right, so just since we have been progressive and adapted to scaled UI’s we get the complaints because many other “big” hosts are still not dpi-aware.


#15

Well there’s nothing we can do about non-juce plugins!

For it to work correctly the plugin needs to implement support for the APIs that pass scaling information around. There’s nothing we can do in the host to magically make them do that!


#16

Totally understand, case closed


#17

We’re currently experiencing this scaling problem. When we open the default JUCE plugin VST3 in the JUCE AudioPluginHost in Windows 10, the UI is very small. We have tested this on 3 different displays.


#18

Ed has been battling the ridiculously complex Windows scaling problems and has finally got a solution that works for all cases, but he’s away for a week - you can expect him to push something as soon as he gets back :slight_smile:


#19

Has this been committed? Because I am facing exactly the same thing (tiny plugin editor in Windows).


#20

Also come across this issue on Windows 7, currently only using the host for testing but will soon need it in an app so great to know its finally been sorted!