Solo/Mute clicking noise when input monitoring is enabled

as the title already says I have this problem, that when input monitoring is enabled on at least one track, soloing/muting a track makes a clicking noise. Has anyone else had this issue or am I overlooking something?

Have you maybe set Edit::processMutedTracks to true?

I’ve not tried it yet, but maybe if you have it setted to true click is caused by plugins that are turned off.

If it’s setted to false maybe it should be because there’s no ramp between the presence of sound and the silence?

Let me know if you will solve it and how :slight_smile:

Do you know where the clicks are coming from? If you take a look at TrackMutingAudioNode, you should see that when mute is enabled/disabled, it ramps the current buffer in/out.

Thanks for your answers. Edit::processMutedTracks is not set to true. I’m having a hard time to find where they are coming from. To narrow it down, it happens when one or more tracks are monitoring input and I solo one of those tracks. I’m on Windows 10 and building with ASIO driver.