[SOLVED] readDoubleValue () [not] broken on develop [!]


I just updated JUCE to latest Development branch (been lagging behind a bit).

Unforunately, this commit from Feb 1 seems to break CharacterFunctions::readDoubleValue(CharPointerType& text) for me

Any ideas what might be going on here? @t0m maybe?

you probably will need to specify your compiler/platform

As well as the version of Xcode and macOS could you also please provide the full error message in the compilation log?

Xcode 12.3 (12C33)
macOS 10.15.7

I’m not sure re compiler, what is the standard with a JUCE boilerplate plugin? That one :wink: I’m trying to make a Standalone Plugin build, that worked pre-update

Sorry, just noticed that it might be me!

I’m integrating the Gen Library by Cycling 74 and it seems to clash with that… i would appreciate input how to handle this in that case :slight_smile: i have no idea how to de-clash this… the gen library file is included in another file, where the Juce Lib is included as well

Can you include the JUCE header before the Cycling74 header?

#undef inf after the gen include

Made sure Cycling is the last thing included and also tried the undef after the include, but to no avail, the problem persisted with both solutions combined.

I resorted to just rename inf to infinity in the juce_CharacterFunctions.h file, which is fine since I’m working on my own fork… This solves the problem obviously :slight_smile:

Thanks for the help though, pointed me in the right direction