Suggestion: JucePlugin_RTASDoesntSupportMultiMono


#1

Hi, I want to disable the “multi mono” mode in RTAS for my plug-ins; is it possible to add a general JucePlugin_RTASDoesntSupportMultiMono macro? That would need:

  • to add this macro definition to AppConfig.h
  • to add the following (juce_RTAS_Wrapper.cpp) after

#if ! JucePlugin_RTASDisableBypass type->AddGestalt (pluginGestalt_CanBypass); #endif
:

#if JucePlugin_RTASDoesntSupportMultiMono type->AddGestalt (pluginGestalt_DoesntSupportMultiMono); #endif

  • and optionally to add the configuration in the Introjucer.

Thanks for considering this!


#2

Yup, sounds like a good idea to me.


#3

'works well, that was so instant! thanks (again) Jules.


#4

is it possible to add this flag to the AAX wrapper as well? Or perhaps a way to disable this functionality in the busArrangement callback?


#5

Jake, here is a patch so that you can set it from the Projucer. It should work right away for RTAS and AAX.

projucer-multimonoAAXRTAS.patch.txt (1.2 KB)

Someone at ROLI might want to have a quick look at this 4-lines patch.


#6

yikes, sorry I thought I didn’t post that!

There is a flag in the appheader.h for disabling it inside of AAX aswell