TextEditor doesn't underline spaces

As the title says. The TextEditor underlines all characters except spaces. I used the following code at the end of my MainComponent constructor.

Font font{};
mainView->setText("Testing if spaces are underlined.");

I found a topic about this on the forum but it was from 2011 so I assumed it’d be ok to post a new topic about it.

Seems like that would be a good option to be able to set. I don’t like underlining the spaces between words, (or punctuation, really). But I see that (for example), Mac’s TextEdit does apply underlines to spaces, so obviously some people prefer it that way.