URL createInputStream and juce 1.46


#1

Hi All,

I’ve recently updated to the 1.46.
I had no major problem except one.

I use the URL class to connect to a php script on a server using POST method.
It still works fine on windows with 1.46 but no more on the mac.

(it still works using 1.45, there has been no changes on the server side)

I still can successfully create a stream using creatinputstream but there must be a change in the platform specific code that add something the server cannot understand.

instead of giving back a string, the server answers:

413 Request Entity Too Large

Request Entity Too Large

The requested resource
/scripts/myscript.php
does not allow request data with POST requests, or the amount of data provided in the request exceeds the capacity limit.
Apache/2.2.3 (Red Hat) Server at myserver.com Port 80

my url command is still the same as before:
http://myserver.com/myscript.php?action=myaction&source=mysoftware&productid=1423&serial=67867867-67867867-68676867-76876867&mid=ABCDEFGHAB

I have to release a update soon.

please help!

cheers


#2

It seems there is an error in the current mac impl
if you use some URL rewriting on your server.

Is that the case ?


#3

HI,

thanks for your reply.
I’m not expert on server stuff but i can see in our httpd.conf that the mod_rewrite module is loaded.

is there a workaround or a fix?


#4

In our case we have removed the URL rewriting as it was not really required, but in your case it might not be possible.

Good luck


#5

I think the only change was that I made it ask for http1.0 instead of 1.1 to avoid some formatting problems. Not sure why that would have the effect you describe though.


#6

yeah that’s strange.
i tried putting back the old juce (1.45) files (juce_network and juce_URL) and it works again so it’s probably related to this change


#7

Hmm. Ok. I guess I need to put back the http1.1 and work around the other problem instead.