URL::readEntireTextStream broken, if usePostCommand is true


#1

The URL::readEntireTextStream does not work correctly anymore in the latest tip on Windows.
It works ok if I you send your parameters as GET, but if you set the ‘usePostCommand’ true, it always returns an empty String.
This worked correctly with a tip before April 2010.

I tracked it down to the juce_win32_Network::juce_openInternetFile and the URL and the POST data created from the parameters are correct, but the result isn’t.
I double checked with several test sites on different servers and on my local machines XAMPP - it’s always the same.

As already mentioned, this worked before. There must have been some changes after April that broke this. Haven’t checked that on Mac, yet, but the Windows code is definetly not ok.


#2

 

 

 

Is this still broken?  I saw this issue before, but I thought it had been fixed (haven't tested lately myself).

 

Also - Jules - what do you think about adding an optional timeout parameter to readEntireTextStream?

Currently - If there is no network connection it comes back quickly, but if the DNS is out, then this will hang for a looooong time.

 

 

 


#3

I doubt if it's still broken after 3 years, but let me know if it is.

Re: adding a timeout - you can easily write your own version of readEntireTextStream if you need something more flexible, it's only 4 lines of code!