Validation Failure

Desperately need help - I’ve been developing a simple plugin and suddenly my DAW (Logic X) can’t validate the plugin, and I can’t think of anything I’ve done to affect this (I was just twiddling Slider parameters at the time, and have un-twiddled them just in case but with no improvement on the situation).

Validation result on any new plugin I try to compile (my previously compiled plugins still work):

Manufacturer String: yourcompany
AudioUnit Name: willthiswork2
Component Version: 1.0.0 (0x10000)

* * PASS
JUCE v5.3.2
FATAL ERROR: OpenAComponent: result: -1,0xFFFFFFFF

validation result: couldn’t be opened

This even happens with a fresh Projucer project. Anyone got any experience or knowledge to what’s going on here? This error message means nothing to me!

OSX 10.13.5 | Projucer 5.3.2 | Logic 10.4.1 | Xcode 9.4.1

This is probably because you need to reboot or rename. I learned this recently; see below.

Thanks for the suggestions - I’ve tried rebooting, renaming, & auval in terminal, but with no success yet

Naively, this looks like a memory-related error or something with permissions…

FATAL ERROR: OpenAComponent: result: -1,0xFFFFFFFF

Where is the file located?

Also, did you see the last post in this?

Here is another one with some decent info. AU validation errors

You might be onto something with that - It’s also sometimes similar;
FATAL ERROR: OpenAComponent: result: -50,0xFFFFFFCE
It’s located in my local user library plugins folder. Tried putting it in HDD/Library/audio plugins folder, but couldn’t get it to appear at all by auval.

Thanks for more links - I’m going through them right now.

Well, this remains unsolved on my third day of bashing my head against it.

Broadly, I’ve tried;

  • renaming
  • changing location
  • rebooting
  • reinstalling
  • updating (yet to try downgrading…)
  • deleting caches
  • changing permissions
  • changing flags
  • modifying plist
  • modifying AU wrapper project
  • and a load of code that didn’t have any affect

Anyone got any suggestions? It’s probably something stupidly simple cuz i iz a no0b.

What is your o/s, projucer, etc. versions & what are your project settings?

OSX 10.13.5 | Projucer 5.3.2 | Logic 10.4.1 | Xcode 9.4.1

What sort of settings? There’s lots - broadly;
I’m compiling just for AU
Avoiding numbers in fields (someone else had this problem), otherwise all normal alpha symbols

Good point; likely very frustrating. One of the things that I noticed a bit ago had to do with deployment target, osx architecture, etc. not matching. Sounds like it, but just to be sure…are you using Projucer defaults or have you modified those?

If I were in this situation, I would build a VERY simple version of this project from scratch (which works) and then add a few things at a time and test along the way. Its a pain if you don’t do it from the beginning, but if your project is not huge, it may be easier than further head bashing.

Thanks - Can you elaborate on what you mean by deployment target, osx architecture, etc. not matching?

I’ve tried building fresh projects with absolutely no modifications or personalised code and this error still occurs.

I’d be able to follow some line of investigation, if only I had any clue where to start - this error message is entirely unhelpful!

Do the JUCE example plug-ins work?

The tutorial plugins are suffering the same fate;
Compiling just fine, failing validation.

Well it’s likely to be machine config issue then, rather than anything in JUCE. Sorry that doesn’t narrow it down too much.

A shortcut to validation is running auval from the command line. If you do

auval -a

that will validate all plug-ins on your system. You can then look at the identifiers next to your plug-in to validate just a single one. For the JUCE plug-in demo on my machine that would be

auval -v aufx Rt46 Manu

which validates fine.

Thanks t0m - I’ve run the auval before with no luck. Just ran it with a couple of tutorial plugins, and hit the same problem.

Suspect you’re right about it being a machine (or at least a not-code) config problem. I was tweaking code that what I would not deem sensitive to causing this sort of headache!

You might also want to try Dave’s pluginval on it:

…just in case it throws up any more clues.