AU validation problem!


#1

Hello,

I can’t validate my plugin anymore which creates this error log at AU validation of Logic. Could you please translate what this is ? The VST and standalone versions do work fine. I have tried to delete all the caches related to Logic, plugin itself, and AU on the users library, however this problem remains.

TESTING OPEN TIMES:
COLD:
2017-12-19 14:47:34.559 auvaltool[1560:24629] Error: Session 44CCD6FD-9770-41AC-B860-9644132FBAB1 was unable to communicate with the remote service: Error Domain=NSCocoaErrorDomain Code=4099 “The connection from pid 1561 was interrupted, but the message was sent over an additional proxy and therefore this proxy has become invalid.” UserInfo={NSDebugDescription=The connection from pid 1561 was interrupted, but the message was sent over an additional proxy and therefore this proxy has become invalid.}
FATAL ERROR: OpenAComponent: result: -10863,0xFFFFD591

validation result: couldn’t be opened


#2

any comments ? Is this JUCE related at all ? Or does the AU plugin try to communicate with Juce server etc. ? Sorry I am not an expert on that field to understand what’s going on or written on this message.


#3

Do you by any chance got AUv3 also?


#4

unfortunately not. However I try to delete all the copies of this plugin , and Logic (or auval on terminal) tries to look for this and gives the same error every time. Also Reaper tries to load it with the same name. I can’t succeed to get rid of it. I have deleted all the Caches on users’ library. What does actually this message mean ?


#5

Are you capable of building the product provided to that machine?

Try building it without the standalone app. And make sure the stand-alone app is deleted from the machine.


#6

yes, I can build the VST and Standalone versions, which work fine. And I have also deleted the standalone version for a clean AU validation. I haven’t tried to build the AU plugin without the standalone app.

The problem seems that Logic / Auval is obsessed with looking one specific copy of this plugin, and I can’t change it. It is listed among the AU plugins which can’t be validated.

Usually if you delete a plugin from the harddisk then the AU list on Logic also discards its name from the list, but this one remains. Even if there are no plugins on the harddisk, the Auval commandline tool on the terminal finds it again and produces this error. I don’t understand how it can still find it ! I suspect of a corruption in the system. All these happened suddenly after updating the Xcode, Logic and OSX triangle.


#7

Whenever we experience issues like this the magic formula normally is…

  • Make sure the plugin is definitely not on disc in either ~/Library/Audio/Plug-Ins/Components/ or /Library/Audio/Plug-Ins/Components/
  • run auval -v x x x (don’t worry about this failing, it seems to clear some sort of cache, I guess because it went looking for something that doesn’t exist)
  • log out and back in again

#8

all these steps are followed already , thanks!


#9

I solved the issue by changing all the plugin id’s naming etc. even the company name, likewise it showed on another AU folder on the AU validation list of Logic. After successfully validating it, Logic forgot the previous folder and the never validated plugin name. Then I have changed again the plugin id’s to the original and likewise trapped Logic ! This situation has nothing to do with Juce, it is the weird AU validation process of Logic which with every update of Logic pops up again and again.