VST plugin not found (fl studio) on new m1 mac

I have a new m1 macbook pro.
I pulled my juce project which was previously working on my intel mac.
Xcode built my vst3 and I set fl studio to search for the appropriate folder.
It’s not picking it up the plugin during scan, but there are no errors

Is xcode building for intel (and how can I tell?)

It’s been over a year since I worked on Juce, I might be forgetting a build step,

Thanks

The DAW & Plugin need to match in CPU architecture. i.e. If FL Studio is running native, the plugin needs to be build for M1. If the DAW is using Rosetta, the plugins needs to be build for X64. The easiest would be to build a universal binary & test again.

Are you using the Projucer or CMake?

I’m using projucer.
I checked that fl studio is running native m1, and my output build is native, but this didn’t work

I also tried building “any mac” and that didn’t work either.

I tried different folders, restarting, I’m a little perplexed

I’d like to revive this.

I’ve tried every target configuration for my plugin in xcode, even cycling through all of the options here in projucer:

And the plugin will show in Ableton but not fl studio, even though both are running native m1 as shown:

I’ve updated my OS to Ventura 13.1, updated fl studio to latest and updated projucer to latest.

The plugin is definitely in the fl studio scanned folder.
What is different about fl studio? Do I need to sign the plugin?

Edit: looks like the build was exporting to the wrong library folder. I navigated to library/audio/plugins and dropped the vst in and it was then picked up