VST2 XP SP3 compatibility with VS2015


#1

Hi guys,
anybody got VST2 plugins built with VS2015 (toolset 140xp) working on Windows XP SP3?
I’m building with /MT, so I supposed that would be enough… but unfortunately not.

Thanks!


#2

For Windows XP in VS2015, you need /MT, the toolset 140xp, and DIrectWrite disabled (+32 bits platform since most of XP users have a 32 bits XP)


#3

The JUCE framework does not work with Windows XP anymore. You need a very old build to make this happen i guess. Our plugins do not work on XP anymore.


#4

We certainly haven’t officially supported or tested on XP for a long time now, but TBH there’s actually nothing I can think of in in the codebase which would stop it working if you can persuade the compiler to generate the right executable.


#5

My fault. Seems that it is related to VS 2015.
I also tried the toolset for 140xp and had no success. It seems that it’s not possible to build for XP with VS 2015:


Do plugins need Visual Studio redistributable?
#6

There are still a few people that have old Windows XP machines with a stable configuration and some older hardware attached. They mostly only use it to run a single synth plugin and have no time / money or motivation to update that system.

The solution i mentioned here looks promising:


#7

Thanks Patrick! I tried what said in the other thread… it looks to install but it still won’t show under any DAW. I also installed on the XP SP3 machine the latest VC Redist, but without any luck.


#8

Fixed. I messed up a thing and now works!
Thanks!!!