VST3: 64 input channels not possible?


#1

Hey all,

I’m working on a special purpose plugin that needs up to 64 input channels on the bus it’s inserted in.
In the constructor, I just add one sidechain input and in setPrefereedBussArrangement() I refuse only channel sets larger than 64 channels and otherwise return the value of AudioProcessor::setPreferredBussArrangement().
When I periodically check, getMainBusMaxInputChannels() returns the following values when testing in Reaper:

Reaper Channels = 1 - 14 => correct value
Reaper channels = 16 or 20 => 14
Reaper Channels = 24 - 64 =>19

Am I doing something wrong or is such an input channel count not possible?

I’m on JUCE 4.2.3.


#2

Have you tried this on the latest JUCE. I wouldn’t see why this would not work in the latest JUCE.


#3

I downloaded JUCE 5 yesterday an tried it. Same result.

My Constructor’s initializer list:

PluginProcessorBase is a class derived from AudioProcessor. The constructor argument is properly passed to AudioProcessor’s constructor.

isBusesLayoutSupported does this:

Setting Reaper to 64 channels:

yields this result:

and getMainBusNumInputChannels() returns 19.

// EDIT:
This is about VST3 on Windows if that is of any concern.

// EDIT2:
Any idea @fabian?


#4

Hi @rip-off,

There were some speaker enums missing in the VST3 wrapper which REAPER tries to use when the channel count is high. I’ve added all the missing enums (and a fallback if REAPER sends us any speaker enums which aren’t defined in the VST3 SDK yet) with commit #643bbdc.

However, even with the above commit, I cannot get more than 24 channels. But debugging the VST3, I see that reaper never even tries to request anything more than 24 channels. It seems to me to be a limitation of REAPER using VST3. Are you sure you have seen other VST3s which support 64 channels in REAPER?


#5

Hey @fabian,

sorry for the late reply - I was vacationing.

I am absolutely not sure that I have seen this working anywhere.
The plugin will run in a version of Nuendo that has been patched by a third party (not Steinberg themselves) to allow for those channel numbers so it’s a bit hard to test but we’ll definitely give it a go with your fix.