VST3 Broken on Mac/Develop

Seems like a commit that was done yesterday prevents any VST3 plugins (even just blank template ones) from being scanned by hosts. In some cases if the plugin was scanned from a version that worked, it would show up but not launch.

I tried it on Intel Mac/Big Sur, on Ableton Live and PluginVal. VST2 seems to be fine, as well as standalone.

The problem seems to be related to this commit:

Anything before that runs fine and does not show the error message.

The actual error that shows up is:
error: Failed to load plugin: bundle does not export the required 'bundleEntry' function

Actually, I am having a weird problem that might be related to this. After updating to the develop commit today, when I build my VST3 it ends up being like 8k in size, instead of many MB like usual. And of course it won’t load… because it ain’t all there.

I’m trying to track this down, and what flagged me (to this post) was that in the debugger, it is failing on line 945 of juce_VST3PluginFormat.cpp when trying to load the bundleEntry function:

 if (CFBundleLoadExecutableAndReturnError (bundleRef.get(), &error.object))
    if (auto* proc = (EntryProc) getFunction (entryFnName))    // FAILS HERE
       if (proc (bundleRef.get()))
             return true;

I then went to look at my executable and found the size problem.
Did you check the sizes of your executables?

I can confirm this, on both Mac and Win, the VST3 file is just a few KBs instead of MBs.

We have a fix on the way for this. It’s just making its way though our CI.


Looks good now on develop, thanks @t0m!