VST3 questions

Hi,
I’m trying to build my plugin as VST3. By default it seems to be VST2 compatible, since it’s not finding the VST2 headers. I know they have been removed, so that’s no problem. But how do I disable VST2 compatibility in Projucer?

And concerning the VST2 compatibility: Does this mean I can build a VST3 plugin that would als be recognized by DAWs that only support VST2?

To disable VST2 support, go to Modules -> juce_audio_plugin_client and set JUCE_VST3_CAN_REPLACE_VST2 to disabled.

1 Like

Does this mean I can build a VST3 plugin that would als be recognized by DAWs that only support VST2?

No. The change deprecated the VST2 wrapper in the VST3 SDK.

Thanks for answers. Everythings working and everythings clear.