Xcode 4.4.1 and AU plugins... Huh?


#1

I just “upgraded” to latest version of Xcode which is currently at version 4.4.1
At the same time I took the opportunity to reinstall OSX, so I have nothing remaining from my previous OS install.

Go figure… Is Apple removing support for Audio Plugins? (No probably not…)

Recently, Apply converted Xcode into an “AppStore App” which imply they have to redefine all paths = no files outside the Xcode bundle.
For example, there is no /Developer folder anymore, but most people knows this, I suppose. The Audio Unit sourcefiles had to be downloaded
as a separate SDK download. Ok, I can buy that…

But NOW, in version 4.4, this separate download no longer exist? (Of course you can download some old SDK, but the download
for version 4.4 just doesn’t contain any source files, only AuLab etc…)

Could somebody guide me in the right direction? How do I build an AU under Xcode 4.4? Or let me rephrase that: Aaaarggghhhh!!!


#2

http://www.rawmaterialsoftware.com/viewtopic.php?f=8&t=8682


#3

Thanks Jules, but it would seem that it’s completely irrelevant to version 4.4, the problem being the apparent absence of the SDK itself. This change seem to have occurred between 4.3 and 4.4 (?)
The change may not be so apparent if you upgrade from 4.3 to 4.4 as your files on disk would still remain. But a clean install… Huh!?


#4

I don’t understand your point… You don’t need the old SDK, you can get the audio files that you need if you follow the instructions on that other thread.


#5

Ah, my point being, that when you download the SDK from Apple, there are no source files. I’m not kidding - it’s an SDK without source & header files!?


#6

Which SDK are you talking about?


#7

I’m talking about the SDK used to build AudioUnits. (The AUBase.cpp, AUBase.h etc…) The Apple files you have to include to build your AU. On the web site they are called “audio tools for xcode” or something, except for Xcode 4.4 there’s an updated package- with no source & header files. (The package is said on the web site to contain those files, but inside, they are not.)


#8

Oh, I see… Well they must be somewhere, otherwise nobody could create any AUs… Have you looked on the Apple support boards about this?


#9

The only reply I’ve seen on the Apple mailing-list regarding this is irrelevant. :frowning:
I can imagine that lots and lots of people doing AU’s on Xcode 4.4 are still pointing to old files they had on the disk while upgrading Xcode from a previous version. (?)

Thanks for your help Jules. I’ll ask around and post here if I learn anything.


#10

Do you know if anything has actually changed in CoreAudio? The old February release is still available from the Apple download page which does contain a CoreAudio folder. Does this still work?


#11

I suppose, sort of. I get the same compile errors lots of other people get, but I have yet to build successfully with that version, partly because I may have f#¤%d up my project file. :roll:

Worst case is that I use those old files, but the version of the “SDK” that I downloaded was specifically for Xcode 4.4, so it makes me think Apple is up to something and I don’t want to start patching my setup until I know for sure what Apple is up to.


#12

Did you install the command line tools from XCode’s preferences?

I have AudioUnit.h in /System/Library/Frameworks/AudioUnit.framework, and that seems to be being picked up in a quick test compile[1].

My system is a new 10.8 MacBook. I did a Time Machine migration from an older 10.7 laptop, so I can’t hand on heart say this stuff came with the XCode install, but the file stamps are newer than they would be for migrated files.

[1] I don’t do AU code, so I can’t say whether it works in any useful sense.


#13

Thank you for looking :slight_smile: In the Framework folder there’s a limited set of header files. I honestly don’t know
the purpose of them, in conjunction with the SDK, but the SDK contains a much larger set of headers - and sources.
So those are not the files. :-/


#14

Hello!

I tried myself to get the Audio Plugin Demo of JUCE running with Xcode 4.4.1.
It was missing some headers as mentioned earlier in this thread. So I downloaded the Feb. Audio Tools and inserted the Folder into the Xcode-App-Bundle as done by others, too. Now it finds those headers and the next step would be to fix those errors in these files and here is where I could need some help. The first error Xcode complained about was two missing casts: “static_cast(…)”. I inserted them with an external text editor (Xcode would crash when its done its internal editor). The next error is on this line, found in “AUMIDIEffectBase.cpp”: result = This->MIDIEvent(inStatus, inData1, inData2, inOffsetSampleFrame); It says: Member “MIDIEvent” found in multiple base classes of different types.
How do I get rid of this one? Maybe someone can give me a hint on the following errors, too.

Thanks in advance,
StrangeMan

PS: It still feels strange to me to edit these files. Are you sure, that is the only way to compile AU stuff with Xcode 4.4.1?


#15

Never mind, I found the solution here later: http://www.rawmaterialsoftware.com/viewtopic.php?f=4&t=7752


#16

[quote=“StrangeMan”]PS: It still feels strange to me to edit these files. Are you sure, that is the only way to compile AU stuff with Xcode 4.4.1?[/quote]Yeah, it’s just plain wrong. I haven’t tried to compile this version of the source code with an older compiler, but the code is incorrect. A proper compiler should not compile the code - so WTF? Did they forget to test-build before release? Have Apple not yet come around building it since February? :cry: