10.5 oddities


#1

Hi All!

One of my users has reported this weird error:

It’s a Macbook, OS 10.5.1 …

Can any of you give me a clue as to what might be going on? I haven’t got Mac OS 10.5 yet… :frowning: … I wonder if its related to that. Erk!

Thanks in advance!

Pete


#2

…could be that Apple have changed something, but it’s a bit odd, as everything’s working ok in every OS10.5 that I’ve seen. Presumably it’s related to the colourspace stuff in juce_mac_Windowing.cpp, in the MacBitmapImage class - maybe CGColorSpaceCreateWithPlatformColorSpace() is failing for some reason…?


#3

Oh dear - sounds like I need to buy Mac OS 10.5 and put it on a spare hard drive… :frowning:

Pete


#4

Hi Jules,

Just to double-check, did you make any changes recently (in the past 1 or 2 months) to the svn sources, specifically related to fixing any issues in 10.5.x?

Thanks in advance!

Pete


#5

There might have been a couple of changes in there since the last version. I’m also not yet using 10.5, but there are plenty of people on the forum who are, I believe.


#6

Can’t see any recent changes in the svn tree related to CGColorSpaceCreateWithPlatformColorSpace … crumbs, I wonder what the problem is… oh well! :frowning:


#7

There’s a line in the code where I commented-out the use of an RGB colourspace because it was too slow. You could get them to try a version with that re-instated?

And ask them to try some other juce apps, like the demo.


#8

Jules, you are the man - great suggestions as always. :slight_smile:

Pete


#9

Hi Jules!

FYI, just tried noatikl on Mac OS 10.5, and it didn’t crash!

This was on a fresh install of Leopard.

Caveat: I can only try with 10.5; I can’t upgrade to 10.5.1, as whenever I try, the MacBook hangs after installing the system updates; and when I finally have to force the machine to restart, the mac won’t boot! I have tried 5 times now (!!!)

My system: installing Mac OS X 10.5 to separate USB drive plugged-in to my MacBook (which has 10.4.11 on its internal drive). The “basic” install of 10.5 works, and I can re-boot OK from this; it is the first system update that makes it all fail!

Mac OS X 10.5 = VERY buggy, avoid it if you can until the bugs are fixed!

*** However… :slight_smile: *** Jules, there is a bug in Juce on 10.5, in that my apps position themselves (when first displayed) such that their title bars are behind the Mac native menubar!! This means that we can’t actually move the app around the screen. :shock:

This sounds similar in concept to the pop-up menu scrolling bug you fixed a month or so back. I hope you can fix it. :slight_smile:

Pete


#10

Wow - I didn’t think anything could go behind the menu bar. I’ll investigate when I finally get a copy of the wretched OS…


#11

Jules - be careful - make sure you put it on a separate external drive, to prevent trashing your existing setup!!!

Looking forward to the fix as and when. :slight_smile:

I’m advising anybody who’ll listen not to use 10.5.x for now. Even Vista installs were more sucessful - Apple resting on their laurels, perhaps? :shock:

Pete


#12

Hey, I’ve been away for a while busy with intermorphic coding (noatikl and all) and have just taken a second look at Mac OS 10.5 …

The good news is:

  • 10.5 now installs to my external drive OK (with the 10.5.2 software updates; before, it worked until the updates were installed but from that point on I couldn’t boot off the 10.5 install on the external drive!)
  • you need to remember to install the 10.3.9 SDK using one of the custom install options.

I’ll let you know if I have any problems; and what the work-arounds might be! :slight_smile:

10.5.3 is just around the corner apparently… a friend of mine has a Mac Book on which his copy of 10.5 has never allowed wireless networking (ironically, this works OK in his Vista dual-boot on the same machine!); I hope this will be fixed in 10.5.3 … :-0

Have fun folks!

Pete


#13

I still have issues of the white blank screen (window) persistent on some Leopard machines.

I have the following line commented in MacBitmapImage and it does not seem to help.

//colourspace = CGColorSpaceCreateWithName (kCGColorSpaceUserRGB);

Any help would be greatly appreciated.

Thanks.


#14

Any clues about what’s different on the machines that exhibit this?


#15

While there are not many things in common so as to define a pattern, they are all on 10.5.2 (Its a couple machines on the client location)

Is there is anything more in the code that needs be commented or changed ?

Thanks, Jules.


#16

Can’t think of anything that might affect it. I’m using 10.5.2 myself, but haven’t seen any problems…


#17

:frowning: Does having Radeon X1900 video card make a difference for the negative ?

Thanks,
Anil.


#18

Unless there’s a bug somewhere in Apple’s display code, then I don’t think the graphics card could make a difference.


#19

We got the same problem with 2 customers (completely white window, active when you click at the right place).

Their computers are as different as you can get (PCI versus PCI express, ATI-based versus nVidia-based graphics card)
Only one thing in common : they are using a 23’ Apple Cinema HD monitor, but I doubt this is the root cause.

I haven’t check uncommenting “CGColorSpaceCreateWithName” yet.
Thanks for you help.


#20

Past few months we are regularly getting customer complaints about white screen at launch and we have not been able to give them a convincing solution till now.
I have gone through some earlier posts in this thread and found a solution where in you have asked to uncomment lines of code.
Can you exactly pin point the file and the function where we have to uncomment the line?
Please send in a response at the earliest as this issue has been plaguing us for quite a while now.