AAX on Pro Tools 12 with Yosemite


#1

Hey all,

We're having an issue with Pro Tools 12 and our AAX plug-ins. When the plug-in GUIs are open PT12's own GUI becomes really sluggish (for example the timecode update begins to stutter). This seems to happen when the plug-in GUI is requiring a refresh; if the plug-in needs to be continually refreshed (because they have meters, for example) then the Pro Tools GUI is always sluggish, until the plug-in is hidden.

Pro Tools 10 is fine, so this seems to be a 64-bit, Yosemite, PT12 issue...

I have tried several different approaches in the code but cannot find a solution. 

Any ideas? Anyone else seeing this behaviour?

Cheers,

Mark


#2

Works fine here on 10.8.5 with PT 12.2. Dev build and a debug version of my plugin with lots of meters…. Perhaps it’s a protection check/thread issue?

Cheers,

Rail


#3

Even with the protection code compiled out the problem remains. It seems to only affect Yosemite. I searched on the Avid DUC and saw a few similar reports, but most of them were resolved with Pro Tools 12.2 and Yosemite 10.10.4. 

 


#4

We're still struggling to find a solution to this. 

Has anyone else noticed the Pro Tools GUI stuttering when their plug-in GUI requires a refresh? 

Since it only happens on OSX, it surely must be something to do with the Core Graphics calls in the AAX Wrapper? 


#5

Do you have any overlaying elements? (components...)

Are you using svg based UI or pixel-based (png)?

 

I'd first hide/comment-out elements one by one seeing where's the culprit.


#6

So switching to OpenGL to render some of the elements seems to have solved it for now. But it also introduced some graphical artefacts. Sometimes the outline of a component's bounding box is visible when it's being moved.


#7

I had the same problem today, in my case I had 6 paths each having an "addPieSegment" refreshed with a 40Hz timer. Shouldn't be a problem for the engine, but it's as you describe it, all ProTools GUIs stutter even over seconds... Happens on OSX 10.9 as well.

I will check if it happens with all paths or only PieSegment.


#8

I could trigger this with the single line of code. It didn't happen with other paths e.g. addEllipse.

Now I updated my Juce to the latest tip, and I can't reproduce it any longer. Although can also be completely unrelated...