Ableton AU UI not show up


#1

Hi together,

First i have to say that i like the new modular system :slight_smile:

Maybe someone knows the solution for this issue. I’m using a new tip after the juce quake and could reproduce the issue with the juce demo plugin. I do following:

  1. start the latest ableton live demo
  2. load the juce demo AU plugin to a track
  3. delete/remove the juce demo AU plugin
  4. load the vst demo plugin
  5. delete the vst demo plugin
  6. load the AU plugin —> the ui does not show up anymore (no crash)

I set the suffix in the build preprocessor settings (JUCE_ObjCExtraSuffix=LSSDJEqVST32bit, JUCE_ObjCExtraSuffix=LSSDJEqAU32bit). I know its not the fastest way, but i do following to get different suffix:

  1. Build the VST and AU the same time like in the demo plugin.
  2. Rename the AU plugin in finder and set a new suffix in XCode
  3. build the plugins again, delete the new AU and rename the one with the old suffix back the the original name.

Is there something i miss? What is JUCER_XCODE_MAC_F6D2F4CF ?

Edit: I’m pretty shure that the suffix worked, because the file size is different.


#2

Got the exact same problem here. It looks like the 2nd time the AU is loaded, Ableton thinks its UI is already opened, so it doesn’t go through all the calls to open it.


#3

I could reproduce it also with another plugin that has a different suffix. I remember the keystroke issue:

http://www.rawmaterialsoftware.com/viewtopic.php?f=8&t=5453&hilit=ableton+Keystrokes

It looks that something is wrong with the AU UI’s in ableton live.


#4

This fixed it for me: http://gruntthepeon.free.fr/blog/index.php/2010/03/10/39-avoiding-objective-c-class-name-conflicts-with-brute-force


#5

Its really brut force, will try that. Thanks for the link!


#6

Relevant:
http://www.rawmaterialsoftware.com/viewtopic.php?f=2&t=9287


#7

[quote=“jules”]Relevant:
http://www.rawmaterialsoftware.com/viewtopic.php?f=2&t=9287[/quote]

Great, thanks a lot!


#8

Bumping this since the issue was still happening in the tip with Ableton Live 9 x64. See this post and followups for details on the fix.