Adobe Premiere gives wrong sample rate


#1

Hi, I’m working on my own plugin and I’ve a strange behaviour regarding the sample rate.

When I use my vst in Adobe Premiere I get always the same sample rate, 44100, in PrepareToPlay even if I change it in the preferences of Premiere.

I saw that some people on the forum had this kind of sample rate issue but I didn’t find any workaround to avoid it.


#2

The JUCE documentation says :

double AudioProcessor::getSampleRate ( ) const
noexcept
Returns the current sample rate.

This can be called from your processBlock() method - it’s not guaranteed to be valid at any other time, and may return 0 if it’s unknown.


#3

Thanks for your reply. But I need the sample rate in the PrepareToPlay to init some resampler and filter dependant of the sample rate.
I don’t have this bug with Ableton Live for example but Premiere always gives me 44100kHz as sample rate…
Since it seems to come from the host (Adobe Premiere) I would like to know if someone found a workaround


#4

Oh right, so the samplerate given to prepareToPlay is wrong because of the host. You might not have any other solution than to trigger your object initializations in processBlock in some manner, assuming getSampleRate returns the correct samplerate at least there.


#5

Thanks for the idea, I tried to call getSampleRate in processBlock but I still get 44100 unfortunately…

I’m totally lost and disappointed by Adobe. It’s not the only bug I have with Premiere, I noticed that the GUI method were called in the background too…

If you would have any other idea to fix it I will be grateful to you.


#6

Maybe a stupid question, but do you get audio data witha different samplerate within the plugin? Maybe Premiere does an internal resampling to 44.1kHz no matter what audio material or setting?


#7

Thanks for your help.
Yes I resample my data but only in the processBlock. For the moment my filter can only work at 48kHz (R&D limitation).

In the processBlock I get the buffer, resample it to 48k, process it, and resample it to the current sample rate. So I should be able to work on any samplerate.

Since Premiere always gives me 44110 causes issue because I always resample from 44100 to 48 but this is not the real sample rate…


#8

Most video NLEs work with the sample rate used in the video and resample the output. Try creating a video with the audio properties 48kHz and I am pretty sure, prepareToPlay will call with 48000, regardless what your audio interface is operating on.


#9

Thanks, it seems to be a really good idea.

However I’m sorry but how could I change the audio property ? Did you mean Sequence -> Sequence settings... ? If yes, I tried it but it still at 44100.

Since I’ve never used Premiere I don’t really know this soft and its settings


#10

Maybe Premiere’s VST hosting implementation is just very poor quality. Do you expect many people actually would be using your plugin in that host anyway?


#11

I wouldn’t be so quick to blame them, although I remember from my previous job, that Premiere was not the easiest to handle. And that was the only integration there, that I didn’t write, so I don’t know the answer.
It’s maybe best to ask on the adobe forum…

Everybody is talking about AV, but either a software gets the A right or the V. Why is it so hard to get both?

There are plugins that are very helpful to have in a NLE, like De-Noiser, De-Esser and Reverbs… so why shouldn’t you create plugins for Premiere…?


#12

I can’t count on my fingers how many times I’ve seen plugins assume 44100 Hz samplerate. Maybe try setting Premiere to 48 kHz, then play a C major on a piano VST and see if you actually hear C major or something which is a semi-tone off. In that case it proves that Premiere is also telling something wrong to the piano VST.

(The difference between 44.1 and 48 kHz is approximately one semitone.)


#13

Unfortunately yes a lot of people from Premiere would use my plugin…


#14

I use a resampler and if the given sample rate is not the real one used it bugs, so I’m sure that 44100 is not really passed. But thank you for you advice, it’s a clever one I will surely use later.

Yes I will ask to their forum but since a lot of JUCE user may have used Premiere I was wondering if anyone have had this issue and fix it.


#15

For reference, here is the Adobe Premiere Pro developer forum.


#16

Thanks for sharing this url. I just realized I posted my question on adobe forum at the wrong place


#17

I managed to fix this issue. For people who would like to know what to do, here is the workflow to change the sample rate to X in Adobe Premiere.

Preferences -> Audio Hardware -> Sample rate: X
Sequence -> Sequence settings… -> Audio -> Sample rate: X

At this moment if the audio file used has a sample rate other than X, we will hear artefacts or random noises in the vst. To resolve this issue, the audio file sample rate has to match a sample rate of X.

Thanks for your help.


#18

probably a stupid question, but what is IDC?


#19

Sorry for the typo, wrong copy paste :sweat_smile: