Android C++0x flag


#1

I'm getting errors because its not turning on C++0x support. I see the change in the jni/ directory, but,

I get this error:
error: 'uint64_t' does not name a type

I imagine this has to do with the version of gcc I'm using (on OSX)? Is there a recommended version? 


#2

I don't use uint64_t anywhere - is that in your own code, maybe?


#3

There's a stackoverflow about it.

Using gcc48, and adding -std=gnu++0x to compiler flags, seems to do the trick. 

 

BTW, on the small/large icons in Introjucer what size (in pixels) should those be? 


#4

So you mean replace the current "-std=c++0x" with "-std=gnu++0x" ?

Re: icon sizes, it scales them to whatever the platform needs when you save the project, so they can be any size. I guess bigger is better.


#5

I didn't try getting rid of the c++0x one, I simply added the gnu one. I don't know if that means there is something peculiar to my setup. This was against android 10, fwiw. I think other platforms this may not be a problem, there was more of a write-up about this (I think platform and C vs C++ were mentioned), but for me the flag worked.

If its resizing the icons, should I be using an .svg file instead of .png?


#6

Ok, seems like having both flags is the way to do it, I'll tweak that.

I hadn't added support for using SVG for icons, but it'd be a good format for that, and is easy enough to add, so I'll make sure it supports that too, thanks!