Anybody seeing repainting glitches with latest develop?

Seems to have started recently. Rects that are dirty aren’t getting repainted for some reason.

Ventura 13.2.1

I was recently having some very unexpected glitches and defining JUCE_COREGRAPHICS_RENDER_WITH_MULTIPLE_PAINT_CALLS=1 solved them. Perhaps it’s related. Haven’t investigated further though.

Since a week i observed artefacts when components are moved quickly (macOS 11.7.4).
I didn’t know if it was related to JUCE code or to mine as i’m refactoring stuff at the moment.

Yes although I’ve not been able to work out how to reproduce the problem reliably yet. I’m seeing it on components that I’m placing to the front in modal mode for an about window. Bits are occasionally not drawn.

In my case the glitches appear when using ComponentAnimator::animateComponent.

I was wondering if it had something to do with this commit but it’s not happening often enough for me to check.

Yes, that’s it. Good find!

1 Like

I just recalled something similar being discussed in this thread. If you remove that commit the UI is constantly redrawing, so we’ll need something to replace it with.

Now I’ve found another situation where some some paths are displayed properly only if the commit above is reverted and JUCE_COREGRAPHICS_RENDER_WITH_MULTIPLE_PAINT_CALLS is disabled.

The paths are not within a Viewport, not using OpenGL, macOS 11.6.7.

I think I am seeing this as well. I am on Windows 10, with a JUCE from 3/6/23 (af2a4a7e2aeb38fbca79529a1d200ecc2621dfd7). It is highly repeatable for me.

I have a Component that has a child Component that is positioned at the bottom of the parent Component (toolWindow.setBounds (localBounds.removeFromBottom (toolWindowHeight));), and when one resizes the bottom quickly, that Component can disappear completely. Here is a video.

I think I can repro the issue, currently investigating.


Sorry about that, this issue should be fixed here:


Perfect. Thanks!

I guess I am seeing something different, since I’m on Windows. Could be my fault, I’ve been putting off debugging it.

At first view it solves my bugs also. Thanks!

it was totally my issue. Since paint and resized are next to each other in my code, I had inadvertently put my subcomponent sizing into paint, not resized! funny how it kinda worked.