AU and META parameters


#1

I have a plugin with a few parameters which depend on each other. To my knowledge, these parameters should be declared as meta in order to be validated properly by Logic.

But, I have strange situation here, because i’ve never declared any of these parameters as meta, but Logic always validates them fine - it simply worked, so i’ve forgot about this meta stuff.

But now i’ve came to a situation, with some additional parameters added, Logic suddenly refuses to validate, because parameters are not declared as meta.

So my question is: is it possible that Logic doesn’t always detect parameters, which should be meta, but they are not ?? Does anyone has any additional experience on this area. Sounds strange, but can’t explain it otherwise…

Thx!!!


#2

The process validating a plug-in in Logic Pro X is still mysterious to me sometimes ! But I think most of the tests that are done there make sense, so every time an issue is picked by auvaltool, it should be solved properly to help the plug-in work in Logic Pro but also in other plug-ins as well ! And I got a lot of validation failures in the past because of parameter changing other parameters without declaring them properly as meta parameters, so that’s something that I do without thinking now so I don’t have any issue or bad surprise like this anymore.


#3

Thanks, your answer confirms my assumptions - from now on i’ll be more careful.