AU Midi controlled effect

Is there an easy way to get the demo plugin project to show up in logic as a “midi controlled effect”?



ok, so i got it to show up in "midi controlled effects by changing jucePluginCharacterstics.h

JucePlugin_AUMainType kAudioUnitType_MusicEffect

but it seems that the midi is not getting though (the keyboard components keys don’t light up as they do on the VST version). Can anyone give me a clue as to what i need to change to get midi to my audiounit?



anyone? it would seem logical that the demo AU should accept midi input, like the VST version.


Well, it’s supposed to be working… I’m messing around with AUs at the moment so will double-check it next time I’m in that bit of the code.

did you check ? that would be a good candidate for not receiving midi

yay! it worked thanx jpo


Hi Oli, I realize this is a super old thread but what was the fix? The link above is dead and I’m curious. Thanks, mate.

I’m afraid that I can’t remember

1 Like

It may have had to do with the proper setting of the checkboxes in Projucer Project Settings > Plugin Characteristics:

Plugin is a Synth
Plugin MIDI Input
Plugin MIDI Output
MIDI Effect Plugin

Also, the Plugin AU Main Type field may need to be set here as well, to kAudioUnitType_MusicEffect.

1 Like

I am certain I have this configured correctly for an AU to receive MIDI from a MIDI track or to be picked up as a MIDI controllable audio effect in Logic. My Projucer settings for AU category and Plugin MIDI input haven’t changed. The only thing that has changed recently is the Projucer version. As of the last two updates, AU is no longer available as a MIDI controllable device.

I just built our most recent code again using Projucer 5.4.5. and AU successfully appears as a MIDI controlled audio effect and can again receive MIDI from a MIDI track in any DAW.

Can anyone else confirm this behavior?