AU plugs "bypassed" in Studio One 2


#1

AU version of Juce Demo Plugin load in Studio One 2.6.3 (64 bit) but makes no sound. I get the same with my plugins, they don't process audio.

Is there a solution ?

At least, can I prevent Studio One from using the AU version ? The VST and VST3 work correctly.

Thanks.


#2

When you say they don't "process" audio, do their processBlock methods get called at all? If so, do they just have the wrong number of output channels or something?


#3

processBlock isn't called.

My plugins have the same configuration as Juce Demo Plugin: {1, 1}, {2, 2}


#4

Hi,

I've just encountered the same problem. It seems that the appropriate functions of AU Wrapper are never called.

Is there any idea about this issue?

Thanks in advance, 

Maria


#5

Do your AU plugins successfully pass AU validation (auvaltool)?

Do they work in Logic/GarageBand?


#6

Yes, it passes AU validation and it has been tested several times especially in Logic without any problem..


#7

What AudioUnit Utility SDK Library are you using?

(1.1? 1.0.3?)


#8

I am using 1.0.4 version. I also tried to use version 1.1 but the problem still remains..


#9

Is this still in issue in presonus studio 3? I've just tried this on my mac and it seems to be woring with the demo plug-in.