AudioPluginHost crashing when i run my program

So i set the executable to AudioPluginHost in my scheme editor, and when ever i run it the build is successful, but AudioPluginHost crashes.

In the debug navigator it shows “JUCE Message Thread (1): EXC_BREAKPOINT (code=1, subcode=0x14b20b6e8)” to me for about 48 different lines of code (only 3 of which i have typed myself).

I have no clue how to fix this considering this is my first time ever using C++, and the fact that it doesn’t even show me anything i could add to help the situation.

i am using macOS Ventura 13.0.1 and im running my code in XCode v14.1,

Based on just this information, people here can’t really help much. You just have to start unraveling why you get the crash, based on the call stack, starting from that code you have written yourself.

You could try posting the full actual call stack here.

ok, so apparently, when i placed a breakpoint on a line of code it stopped showing that message, instead it has started showing “breakpoint 1.1” and every line of code with that message is highlighted green.

now, instead of audiopluginhost actually showing the window before i get the blue beachball, it doesn’t open the window at all.

(edit: i apparently have the ability to move the juce message thread to any line of code i want for some reason)

This is not a crash as such, but JUCE letting you know that the code is missing something. This is a change introduced with JUCE 7 and the code you’re using is most likely intended to be used with JUCE 6.

If you click the small “play” button at the bottom of the screen a few times, your code will eventually run.

The more permanent solution would be to change the ID of the plug-in parameters from a string such as "My Param" to the following: juce::ParameterID { "MyParam", 1 }. This happens in the function where you create the parameters.

1 Like