AudioTransportSource: artefacts when changing buffer size


#1

Hi there,

I’m trying to make a vst based on the “Build an audio player” tutorial .exe I have manged to get my plugin to playback audio with no problems with a sampler rate of 44.1KHz and a buffer size of 1024 samples. Problems arise when I try and lower the buffer size. Has anyone had issues with this?

I have tried everything I can think of to solve it.I don’t think the issue is buffer underrun as I’ve timed the process block and it was only taking 20 microseconds at 44.1 KHz for 128 samples.

Any thoughts on this would be greatly appreciated, thanks!


#2

Which platform is this on? And which audio driver are you using?


#3

I’ve tested it on windows and mac and it’s only happening on windows. I’ve
tried it with direct sound and asio4all on windows 10


#4

Is this a Debug or Release build?

Rail


#5

Debug, I’m just realising I have tried it in release, woops!


#6

through further investigation it seems that I was barking up the wrong tree, sorry for wasting your time!