AUPluginDispatch::No member named 'MIDIEvent' in 'AUBase'


#1

So for some reason after a recent JUCE update (I think) I am getting this error.

I have seen it before relating to an Xcode update but I have no idea what is causing it this time. Has anyone encountered this? The last time I saw an error like this was when I updated to xcode 4.5 from 3.2.6 there is lots of information on that problem already on the forum. I am 99% sure that involved the same error but in a different file?


#2

Ok so a bit more snooping and I realised it is because I had commented it out of AUBase!

// ________________________________________________________________________ // ________________________________________________________________________ // ________________________________________________________________________ // music device/music effect methods -- incomplete /*! @method MIDIEvent */ virtual OSStatus MIDIEvent( UInt32 inStatus, UInt32 inData1, UInt32 inData2, UInt32 inOffsetSampleFrame) { return kAudio_UnimplementedError; }

This was recommended by someone here to solve this error.

So I am really stumped. Anyone have any Ideas?


#3

Oh, got it.

The solution was to uncomment it then do the changes described in this thread http://rawmaterialsoftware.com/viewtopic.php?f=8&t=9546&hilit=AUbase


#4

Hi,

I have exactly the same thing as you

if I comment I have this error AUMIDIEffectBase.cpp:: Member ‘MIDIEvent’ found in multiple base classes of different types

if I don't I have this one /AUPluginDispatch::No member named 'MIDIEvent' in 'AUBase' / error

 

But I can't see what I have to do if I uncommented ...


#5

Ok I found, just have to patch by adding that:


result = This->AUMIDIBase::MIDIEvent(inStatus, inData1, inData2, inOffsetSampleFrame);
 


#6

I am running into this same error, OS X 10.9.2, most recent JUCE, and XCode 5.1

 

Changing to

result = This->AUMIDIBase::MIDIEvent(inStatus, inData1, inData2, inOffsetSampleFrame);

did fix the problem.

 

Is this something wrong with my configuration, or is this something that should be addressed in Juce?

Thanks

 


#7

It's a bug in the Apple files, not something I can fix in juce! This has been discussed many times on the forum, but unfortunately Apple still haven't fixed their code, so you need to just patch it yourself to make it compile.


#8

Thanks for the confirmation, Jules.

...and thanks for the reply so at least the forum represents that this issue is still current.

Apple quirks are definitely making audio plugin / AU programming on OS X an interesting affair.