Building the JUCE Demo with JUCE 3.0


#1

Hi all,

Just pulled the new JUCE from the repository & attempted to build the demo project. I accumilated 18 errors, each of this type:

/Users/Tad/JUCE/extras/Demo/Builds/MacOSX/../../../../modules/juce_core/memory/juce_Atomic.h:326:62:{326:62-326:68}: error: cannot initialize a parameter of type 'volatile int *' with an rvalue of type 'int *volatile *' [3]

I'm running Mac OSX 10.6.8, Xcode 4.2

I'm positive I've mislooked something simple, & I've been searching around on the forums for some time trying to find an answer. Perhaps it is an issue with the 64-bit architecture? The older 32-bit demo still builds fine.

Thanks & a very very merry Christmas!

_muir

 


#2

Hi,

 

JuceDemo project compiles fine here: Mac OS X 10.6.8 / Xcode 3.2.6 / MacBook (Intel Core 2 Duo / 64-bit).


#3

Hmm that's odd.

It's gotta be something regarding Xcode, perhaps some missing external dependancies? 

Attached is a screenshot of one of the errors.

 


#4

There were various changes to GCC and the format of the __sync_ functions over the last few years, and I had to make changes to that juce code to keep it all compiling. Could be that you've picked one combination of compiler + library versions that just don't work together very well.


#5

Ah thanks Jules!

I went into the build settings in Xcode & switched the compiler from the <Apple LLVM> to the <LLVM GCC 4.2> compiler (see attached screenshot) and it built! However it generates 261 warnings all of which seem to consist of Implicit conversion shortens 64-bit value into a 32-bit value . Is this advisable?


#6

There are about a million combinations of Xcode compiler version + SDK version, and I can't make the library support all of their subtle differences. Most people will be building with the new LLVM + new SDKs on Xcode 5, and a handful of people still use Xcode 3 + old SDKs because they need PPC support, so I make sure those are ok, but it sounds like you've picked some wierd intermediate version that doesn't quite fit. If you're targeting 10.5 or later, I'd highly recommend updating to the latest compilers + latest SDK version rather than using old SDKs and Xcode versions.


#7

Good to know. I was actually getting my feet wet with the prospect of updating everything (including making the jump to Mavericks) so that's good news to hear that Xcode 5 is being actively supported. Thanks!