Can not open any audio inputs whatsoever (Windows 10)

I have spent half a day now trying to get audio inputs working in a JUCE project. Tried my onboard sound card, a Steinberg UR12 and my RME Fireface UFX, all with the latest drivers. I keep getting the error “Couldn’t open the input device!”. Also tried AudioSettingsDemo in DemoRunner.exe to make sure I am not doing something wrong - same result. All outputs seem to work perfectly. What is going on?

Thank you very much!

Maybe some kind of windows 10 privacy setting, to allow applications access to the microphone?

Thanks! Finally, audio I/O is working. Here is what I did:

  1. Control panel > Hardware and Sound > Sound: Deactivate all devices that will not be used. For some reason, audio I/O did not work in the presence of other devices (I made sure that the correct devices were selected for I/O so it is not a selection problem).
  2. Settings > Privacy > Microphone: Turn on both “Allow microphone access for this device” and “allow apps to access mic”. This seems to be necessary in order to get access to line inputs, too.
  3. In the JUCE project: Use inputs AND outputs. Inputs alone did not work. Outputs alone seem to work fine.

I am a newbie of JUCE programming (working mainly on windows 10). The same problem bothered me, yet it has been solved! Thank you very much.