Cannot attach to Final Cut Pro (Big Sur) for debugging

Hello people! Happy new year to everyone. :slight_smile:

I have a strange problem with Final Cut Pro in BigSur and I’m totaly out of ideas. So, I want to ask if there’s anyone else with a similar issue.

I’m trying to attach the debugger (xcode) to Final Cut Pro in BigSur, in order to debug my plug-in, but unfortunately there’s not any luck. Nothing happens! The plug-in opens in FCPX as expected, but not in debug mode.

However, I don’t have any problem debugging in Final Cut Pro in macOS Catalina though. And that’s the strange part!

I have tried with XCode 11 & 12. Both are Intel machines. Both have same FCPX versions.
Any idea? Anyone with the same setup that can verify this issue?

Thanks a lot!

System Specs:

  • Xcode 11, 12
  • macOS 10.15, 11
  • Final Cut Pro 10.5, 10.5.1
  • Juce 5.4.7

Is the macOS 11 version of Final Cut Pro loading plug-ins out of process?

Yes it is. Tested on a M1 Mini running 11.1 and FCPX latest (installed on that day, i.e. 10 days ago, currently on the other machine).
The screenshot in the linked thread shows the filename of the external process AUHostingServiceXPC_arrow in Final Cut Pro.

Haven’t tried debugging yet.

I should have been a little more explicit:

Is the macOS 11 version of Final Cut Pro loading plug-ins out of process on an x86_64 Big Sur machine?

Things are different when running on M1 in other hosts.

1 Like