Cannot compile for M1

I have a project I want to recompile for M1.

I’ve tried changing the “Valid Architecture” to both x86_64 and arm64e, to only arm64e, changing the macOS architecture to “native architecture of build machine”. And although I see the arm64e in xCode, I cannot compile - what am I missing?

Finally, to make a vst3 Intel and M1, do I have to have 2 .jucer projects? Or can I have 1 vst3 that supports both architectures?

What do you mean? Is the ‘run’ button greyed out, or do you get compile errors, or do you get a built archive containing code for the wrong architecture? If you are seeing an error message, please include the exact text of the message.

You can use a single .jucer file. This can be used to generate a single Xcode project, which will build a Universal 2 file, supporting x86_64 and arm64.

So, I checked x86_64 AND arm64 (not arm64e?)

Additionally I have “native architecture of build machine” checked.

I open in xCode and I can see it seems to open it for Silicon
Screenshot 2022-04-27 at 7.17.22 PM

When I press on Compile I get a warning, but I click on “Build” regardless

Then I get this error

Screenshot 2022-04-27 at 7.18.54 PM

Try with arm64 instead of arm64e.

So I tried arm64 and x86_64

(again native architecture of build machine selected)

Open xcode and it says “any mac”

Press compile and get the same warning

Press Build and it says build succeeded.

There’s the VST3, but when I do a lipo -info

 Non-fat file: file.vst3/Contents/MacOS/file is architecture: arm64 

It seems to not have compiled the x86_64… of course if I open reaper or nuendo, it wont work as there is not x86_64… (nuendo blacklists)

EDIT: Same happens if I tick all three (arm64 arm64e x86_64)

OK so:

Leaving “mac architecture” set as Default and ticking x86_64, arm64 and arm64e did compile the VST properly.

I will try and compile everything and test and should this work, will post again…whew…