Cannot compile plug-in standalone in 4.2


#1

Hi!

I am in the process of upgrading an audio plug-in from JUCE v4.1 to v4.2. The VST2 and LV2 plug-ins now compile, but when I try to compile the standalone using g++ 4.8.4 on Linux Mint, I get this error:

main.cpp
In file included from ../../../Source/common/widget/plugin_standalone.h:31:0,
                 from ../../../Source/standalone_application.h:30,
                 from ../../../Source/main.cpp:29:
../../../libraries/juce/modules/juce_audio_plugin_client/Standalone/juce_StandaloneFilterWindow.h: In member function ‘virtual void StandalonePluginHolder::createPlugin()’:
../../../libraries/juce/modules/juce_audio_plugin_client/Standalone/juce_StandaloneFilterWindow.h:77:21: error: ‘::createPluginFilterOfType’ has not been declared
         processor = ::createPluginFilterOfType (AudioProcessor::wrapperType_Standalone);
                     ^
In file included from ../../../Source/main.cpp:29:0:
../../../Source/standalone_application.h: At global scope:
../../../Source/standalone_application.h:35:1: error: expected class-name before ‘{’ token
 {
 ^
make[1]: *** [../../../bin/intermediate_linux/standalone_stereo_debug/x64/main.o] Error 1
make: *** [kmeter_standalone_stereo] Error 2

It looks like “juce_StandaloneFilterWindow.h” is missing some includes, or do you think the problem lies elsewhere?

BTW, I am using premake to create custom make files, and ProJucer only helps me in setting up the files in “JuceLibraryCode”.

Thanks for any help!

Martin


#2

Maybe the the standalone filter wrapper needs updating? Instinctively I thought I would simply search the JUCE docs and find out, that’s not possible, which makes them pretty hard to navigate. Anyhow, bottom line is I don’t know. :confused:


#3

Thanks for taking the time to answer! I solved this by using JuceLibraryCode/juce_audio_plugin_client_Standalone.cpp directly. This is a much cleaner solution, anyway… :slight_smile: