Can't see any MIDI CC or pitchbend MIDI input in VST3 plugin?

I followed a tutorial to build a simple JUCE MIDI VST3 plugin that transposes the incoming MIDI. I have this

    MidiMessage currentMessage;
    int samplePos;

    while (it.getNextEvent(currentMessage, samplePos)) {

…but no MIDI CCs / pitchbend / anything other than Note on and Note offs are being printed or responded to. I have been scratching my head for hours - is there something I am missing or have done something dumb?

Did you post the whole code? You need to increment the samplePos.

That’s not extacly true, even though you can’t get MIDI CC out of a JUCE plugin, you can certainly get it into a plugin and output notes.
The above code looks correct, but I can’t tell what the problem is.

I have a working example of a transpose VST3 plugin here:

@eyalamir It is your example that I was running :slight_smile:. Just to be extra extra sure, I re-cloned your repo and ran the whole thing again; same result:

VST3 exhibits no pitchbend / mod / CC as input (as seen (or not seen) by logger). (It only logs NoteOn, NoteOff)

AU does work, however…! (NoteOn/NoteOff/Pitch/CC/Mod)

Any thoughts?

Projucer + JUCE 5.4.7
IDE: AppCode (or XCode)
DAW: Ableton Live 10.1.9

Thanks for your help! (And your repo :))

Do you have other VST3 plugins that have working pitchbend/mod/CC input in Ableton?

Are you using the latest VST 3 SDK? There has been some changes regarding MIDI recently, if I recall correctly.

Do you have other VST3 plugins that have working pitchbend/mod/CC input in Ableton?

Yes, they do.

Hmm I haven’t manually installed VST3 SDK; i’m assuming the one that’s included within the JUCE dir is the one being used - which I again I assume is the latest VST3 SDK version (3.6.13 or 3.6.14)

Alright, so I just tested that example and it’s indeed faulty in Ableton Live and does not accept MIDI CC.
To fix it, all you have to is to add the “Is A Synth” flag in the Projucer and resave. I’ve updated the git repo with that information.

No need to manually install the VST SDK, etc.


That fixed it, thank you!