Can't select audio input device in Browser Plugin


#1

I’ve added code to invoke an AudioDeviceSelectorComponent to the demo browser plugin. It shows the available input and output device correctly, but I’m unable to select an input device. If no output device is selected, then attempting to select an input device returns the combo box choice to <>. If an output device is already selected, the combo box just displays a blank choice after the attempt. The number of active input channels returned from the current selected audio device is zero(pDev->getActiveInputChannels()). I’ve tried executing this on both IE and Firefox on Windows XP with the same result. Does this mean you can’t do audio capture from the browser plugin? Any help on this or pointer to working example would be greatly appreciated.


#2

Are you trying to use asio? A lot of asio devices can’t open unless they have exclusive access, and your browser might already be using the device via dsound.


#3

I’m using DirectX. I’ve also have multiple input devices to select from, so exclusive access shouldn’t be a problem. Finally, I have no problem selecting asio input devices when running a Juce desktop app with a browser open, but that should have no bearing since I’m trying to open the device via DirectX.


#4

Well it makes no difference at all whether it’s a browser plugin or an app, and I wrote a plugin myself that uses audio, which works just fine. Obvious question: what juce version is this? (…I wish people would say this upfront, rather than me having to ask…)


#5

I just tested the code on Mac both with Safari and Firefox with the same results: it selected output fine, but it couldn’t select either the built-in input device nor the microphone.


#6

Version was downloaded yesterday from the tip.


#7

I tried opening a device for input without using AudioDeviceSelectorComponent and was successful. I then called AudioDeviceSelectorComponent afterwards and was able to select another input device.


#8

Well, the AudioDeviceSelectorComp works ok in the juce demo, doesn’t it? Have you tried stepping through and finding out where the device opening fails?