Carbon problem with 64 bit VST


#1

Jules,

I know you’ve added these lines to avoid defining JUCE_SUPPORT_CARBON in 64 bit builds:

#if ! (defined (JUCE_SUPPORT_CARBON) || JUCE_64BIT) #define JUCE_SUPPORT_CARBON 1 #endif

But I still get an error in the file juce_CarbonVisibility.h when building a 64 bit VST, despite this line at the top of that file:

So it seems the above code doesn’t work or is overridden somewhere.

PieterS


#2

Thanks… I think that in juce_IncludeSystemHeaders.h, it should probably say:

#if ! (defined (JUCE_SUPPORT_CARBON) || defined (__LP64__))

…because at that point, I don’t think it’s had chance to define the JUCE_64BIT flag.


#3

yes, that works!