CMake iOS AUv3 No Code Signature Found error

I get following error when i try to download the AUv3 and the Standalone in my CMake generated XCode Project to my iPad device:

Unable to install "PLUGIN NAME"
Domain: com.apple.dt.MobileDeviceErrorDomain
Code: -402620388
No code signature found.
Domain: com.apple.dt.MobileDeviceErrorDomain

Same works with the Projucer generated XCode project.

Some differences to the Projucer export:

  • The AUv3 Signing & Capabilities do not have a Provisioning Profile assigned (text: None Required). I don’t see any iCloud and App Groups permissions for the AUv3 either. Not sure if that’s an issue. Things are there as expected in the Standalone Signing & Capabilities.

  • I don’t see any frameworks , Libraries in the General settings for the Standalone and AUv3 build. Maybe this is expected for the CMake generated project?

I tried a lot of things. The signing settings in XCode seems to be ok and look the same. I don’t think it’s a problem on my system. The Projucer generated XCode project works without any issues and i can download it to the device.

Any help welcome.

I have to ask different…

Was someone able to successfully download a AUv3 / Standalone to a iOS device using a Juce 6 CMake generated XCode project? The same way it worked with Projucer?

Problem is fixed on develop now:

1 Like