CoreImage.framework makes UnitTestRunner fail


#1

Hi Jules.  Congrats on Grapefruit Juce.  Sounds great.

I just built the UnitTestRunner but when I ran it the previously mentioned CoreImage.framework problem reared it's ugly head:

http://www.juce.com/forum/topic/coreimageframework-not-found-after-xcode-7-upgrade

Daves-MacBook-Pro:~ davechambers$ /Users/davechambers/...../JUCE/extras/UnitTestRunner/Builds/MacOSX/build/Debug/UnitTestRunner ; exit;

dyld: Library not loaded: /System/Library/Frameworks/CoreImage.framework/Versions/A/CoreImage

  Referenced from: /Users/davechambers/........./JUCE/extras/UnitTestRunner/Builds/MacOSX/build/Debug/UnitTestRunner

  Reason: image not found

Trace/BPT trap: 5

logout

 

[Process completed]

---------

It also has the annoying consequence I cannot profile my code in Instruments :

http://stackoverflow.com/questions/33550168/how-may-i-change-the-sdk-associated-with-the-os-x-instruments-app

Hope you can fix it.

Cheers

 

 


#2

That project doesn't set a compatibility version, so will default to 10.11, which might cause problems on 10.10 machines. if you set it to be 10.7 or 10.8 compatible, then that'd probably produce something that works.


#3

Thanks.

I just upgraded to El Capitan and the UnitTestRunner works now.