Cubase 7+8 right click issue (+fix inside)


#1

I'm not using the latest tip, but i didn't see any related change, so i'm asking.

When you click on a certain audio-clip you can render it with a plugin. The plugin opens in a separate dialog-window and it seems that all mouse-clicks on popup-windows (which use inside the plugin) are simply ignored?

Was this fixed recently?


#2

Don't remember fixing that specific problem, but we have done various fixes for windowing that may have indirectly fixed it. You'd need to give it a try.


#3

Thanks, i just updated to the latest tip. The problem is still there. Its a Mac-only issue.

 


#4

also confirmed with the juce demo plugin, using cubase 8.0.030, VST2 64bit,  OSX Compatibilty Level 10.7, latest SDK

I added a simple ComboBox to the plugin to demonstrate the issue:

 


#5

Can anybody have a look at this? If Rolis and Steinbergs would work togehter (does latest cubase include a juce based plugin?), i think it could be solved in a few minutes...


#6

Yes, this is on our list, no need to bump it.


#7

Sorry for being so annoying, any news on this topic?

annoying

#8

Hi chkn,

I cannot re-produce this bug in Cubase 7.5. Just like you, I've used the JuceDemoPlugin and simply added a ComboBox. I compiled the plug-in for VST2, 64-bit and OS X Compatibility level 10.7. Any other differences I should be aware of? Can anybody else reproduce this bug?

Fabian


#9

Its defintly here at my side, i just tested again.

Did you use the clip rendering menu? Right Click on an audio Clip --> Plugins --> JuceDemoPlugin

I tested on Cubase 7.07 and 8.0.30 on OSX El Capitan, 64bit, VST

When you click on the Popup, you here the sound "beep" as it would like, when you click outside  a modal window

 

 


#10

just tested, the problem happens also with VST3  (latest VST3 SDK, latest juce, latest XCode), Deployment Target 10.11, OSX Base SDK (latest)

build an tested on OS X El Capitan (10.11.2) on Cubase 8.0.30 (64bit)

 

 

 

 


#11

just to be sure, select  the plugin from the clip-rendering menu

http://i.imgur.com/rwFA6Ba.png


#12

Plugins from other vendors (tried voxengo curve eq), which open also new windows beside the plugin-gui, doesn't seem to be affect by this issue. So this must be a juce specific issue. I tried to debug it, once the popup window was clicked, no move or mousedown/up messages coming through. Any hints? Feeling a little bit alone now. I used the latest tip, 100% unmodified juce.

 


#13

to continue my monologe:

I tried it the same under a complete fresh new Yosemite installation, and the same problems happens again!

So again, here are the facts

-> right clip rendering

-> VST 64, newest SDK, Compatibilty Release 10.7 & 10.11

-> Host OSX Yosemite (clean install) and OSX El Capitan

-> latest JUCE, latest XCode

-> Cubase 7.0.7 & 8.0.30 - 64 bit

I can't believe i am the only one! 

 


#14

I fixed it, i don't know if i fixed it the right way, but at least it works now!

in juce_mac_NSViewComponentPeer.mm in JuceNSWindowClass

  In the Constructor

     addMethod (@selector (worksWhenModal),       worksWhenModal,    "c@:");

  

    //==============================================================================

    static BOOL worksWhenModal (id self, SEL)

    {

        return true;

    }


#15

Background:

Cubase uses the  runModalForWindow: method from NSApplication for the clip render dialog, the only chance to get auxiliary windows to work is to overwrite worksWhenModal to return true (Maybe this should the default for plugin-in builds, or maybe only for cubase/nuendo hosts)

Description:

https://developer.apple.com/library/mac/documentation/Cocoa/Conceptual/WinPanel/Concepts/UsingModalWindows.html

Stacktrace Cubase:

#1    0x0000000128d22c93 in juce::JuceNSViewClass::asyncMouseDown(objc_object*, objc_selector*, NSEvent*) at /Users/christian/cpp_projects/juceQuake/JUCE_latest/modules/juce_gui_basics/native/juce_mac_NSViewComponentPeer.mm:1513
#2    0x00007fffa0762d4b in __NSThreadPerformPerform ()
#3    0x00007fff8a4065c1 in __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ ()
#4    0x00007fff8a3f8397 in __CFRunLoopDoSources0 ()
#5    0x00007fff8a3f793f in __CFRunLoopRun ()
#6    0x00007fff8a3f7338 in CFRunLoopRunSpecific ()
#7    0x00007fff9c3b2935 in RunCurrentEventLoopInMode ()
#8    0x00007fff9c3b2677 in ReceiveNextEventCommon ()
#9    0x00007fff9c3b25af in _BlockUntilNextEventMatchingListInModeWithFilter ()
#10    0x00007fff978080ee in _DPSNextEvent ()
#11    0x00007fff97bd4943 in -[NSApplication _nextEventMatchingEventMask:untilDate:inMode:dequeue:] ()
#12    0x00007fff979bcd22 in -[NSApplication _realDoModalLoop:peek:] ()
#13    0x00007fff979b92d4 in -[NSApplication runModalForWindow:] ()
#14    0x00000001000027d7 in ___lldb_unnamed_function20$$Cubase 8 ()
#15    0x0000000101bb3676 in ___lldb_unnamed_function142154$$Cubase 8 ()
#16    0x00000001019925fd in ___lldb_unnamed_function128539$$Cubase 8 ()
#17    0x00000001003d9e3f in ___lldb_unnamed_function16290$$Cubase 8 ()


#16

bump, i insist this is an issue 


#17

Yep, saw it, just haven't had chance to investigate yet..


#18

Thanks, btw i use a lot of different kinds of auxiliary windows, not only popups (incl. resizableWindow), so a option to make worksWhenModal return true,  should be applied  to every window.