Cubase doesn't see the plug-in


#1

I got a recent copy of the juce repository and followed the redwoodaudio.net tutorial. Build succeeds and the plug-in exists in ~/Library/Audio/Plug-Ins/VST (or ~/Library/Audio/Plug-Ins/VST3 if I select VST3 in introjucer). But cubase doesn't pick it up even after restarting cubase and refreshing the plug-in information. It doesn't matter if I build with VST 2.4 of VST 3.6. There are other plug-ins in ~/Library/Audio/Plug-Ins/VST and ~/Library/Audio/Plug-Ins/VST3 that cubase sees.

I built the Juce Demo Plugin and that worked just fine.

I also tried building a minimal plug-in using these steps.

- Created a new audio plug-in project with introjucer called QuickTest.

- Went straight to "Save Project and Open in Xcode" without changing anything.

- Built it with Build For > Running.

- Verified that ~/Library/Audio/Plug-Ins/VST/QuickTest.vst existed.

- Launched cubase. The plug-in was not available.

- In cubase, went to Plug-in Information and tried clicking both the "Update" button and the "Update Plug-in Infromation" button, but QuickTest was not in the list.

Any ideas?

Cubase 7.5.20

OS X 10.9.4

Xcode 5.1.1


#2

Solved. I had to run cubase in 64-bit mode.