Debugging in CLion

Just switched from Visual studio on windows to mac/CLion, I hope the thing Im missing isnt too embarrassing.

I am not able to hit breakpoints only in .cpp files from a specific target in my cmake project using juce.
CMAKE_BUILD_TYPE is debug, breakpoints can be hit in juce modules (my own ones as well) and code from my test executable target.
The same project is debuggable without any problems in Xcode.

Debugging the template repo that my repo is based on (Pamplejuce) works fine, and copying the exact cmakelists.txt does not help as well.
Things that also did not help:

  • using Xcode generator instead of ninja
  • manually setting CMAKE_BUILD_TYPE to debug
  • removing .idea files to reset clion project
  • fully deleting the full local repository and recloning it
  • compiling as a standalone application

these lines at the end if the cmakelists file
message("cxx dbg flags: ${CMAKE_CXX_FLAGS_DEBUG}") message("cxx flags: ${CMAKE_CXX_FLAGS}")
results in
cxx dbg flags: -g cxx flags:

even these DBG macros will both be executed
`#if DEBUG
DBG(“debug enabled”);

#if defined (DEBUG) || defined (_DEBUG) || ! (defined (NDEBUG) || defined (_NDEBUG))
DBG(“any debug enabled”);

Im using the default (bunlded) toolchain (v3.25.2) and LLDB Degbugger (v15.0.5) from clion.

Just in case, here are all my other cmake settings:

I am on Ventura 13.2.1

For anyone else having this issue - turns out only clion cares about the word case for source paths:

#correct path: Source/config.h
    #compiles and allows debugging on every ide besides clion