This issue has been there for a while and now I’ve finally got the time to report it.
Some time ago these two functions were deprecated in favour of the AudioChannelSet stuff.
The problem is that, when hosting plugins, the corresponding replacements return some generic names, while in the past these functions would return the correct names based on the plugin format.
For instance, for VST3, getOutputChannelName is overridden by the VST3PluginInstance class and returns the correct names by calling the VST3 APIs.
Can this be fixed?