Displaying iOS virtual keyboard type with keyboard/language selector button


#1

Hi,

The default iOS virtual keyboard type of the TextEditor class doesn’t appear to include the keyboard/language selector button (the global icon usually found at the bottom left). Is there a way of setting this to show?

I’ve found that setting the keyboard type to urlKeyboard or decimalKeyboard will display the language selector button, however I ideally need to use the default text keyboard.

If it helps, I’m running iOS 12.1.4 on an iPad Pro.

Thanks.


#2

This icon?

This is a screenshot from the DemoRunner running on an iPad Air 2, iOS 12.0.


#3

Interesting - this is not what I’m seeing.

I’m currently having trouble running DemoRunner on my iPad (will try again tomorrow), but running it on the iOS simulator iPad Air 2 shows me this (which is exactly the keyboard layout I’m seeing in my JUCE app):

This is from the develop branch tip.

However the keyboard within every other app on my iPad displays this button, and I’m struggling to see any device keyboard settings that could change the behaviour.


#4

That is odd, I see the same keyboard when running in the simulator. Not sure why there would be a difference between the two though, and I can’t see anything that we’re doing in the JUCE code that might cause this.