Error message "... is not a valid win32 application" on "audio application" project


#1

Trying to run a new “audio plug in” and fail.
I run it from the projucer, with Visual Studio 2017 on a windows 10 PC.

I get the error message:

Microsoft Visual Studio

Unable to start program
C/Users/…/visual studio 2017/x64/Debug/VST/<project_name>.dll

C/Users/…/visual studio 2017/x64/Debug/VST/<project_name>.dll is not a valid win32 application

Any hints on what is missing ?


#3

It doesn’t appear you are building an application since the end result is a .dll file. (Also it looks like to be a VST plugin build since the path to the .dll has VST in it.)


#4

The wording " audio application" is a typo.
I just now corrected to “audio plug in”. Sorry for the confusion.


#5

You can’t debug/run dll files directly. You will need to set the host application to use in the Visual Studio project debugging properties as the Command to run. Also the built dll file of course needs to be in the folder where your host application is scanning for plugins, so you probably want to add a copy step into your build that copies the dll file from your VS project folder into your host’s used VST folder.


#6

More information:

If I copy-paste the DLL into the host (Abelton live for example) - it runs OK. No error message.

But my probelm is that I try to run it from ‘Visual Studio’s’ “Local Windows Debugger”.
With past set up (other PC), I could use it at a similr scenario. but with current set up, it seems something is missing.


#7

There are two ways to do this: You can select a binary to run in your debugger, so you would select ableton for instance, the Debugger would start attached to Ableton, giving you the chance to debug your plugin, if you load it inside Ableton.

Option two is, to add the “Standalone” to the build targets in Projucer and resave the project. Now you can run the plugin in a minimal wrapper.

I am not on windows atm, so I can’t provide screenshots or specific menu names…


#8

The project needs to be set as the “startup project” in Visual Studio in that case but I think Projucer sets that automatically when the standalone application wrapper is added into the build configuration.


#9

Thank for the help.

It seems to work, though I’m still playing with it.
It seems that projucer did not change the debugging option to stand alone automatically.