Right now most container (or container-like) classes have isEmpty () or empty () functions. Only very few have isNotEmpty () functions. This makes it hard to remember which class has what (even though modern IDEs help figure that out), but it leads to awfully inconsistent code.
if (container.isEmpty () == false)
seems super weird, when you’ve used
if ( conatiner.isNotEmpty ())
for other containers before.
Some container-like classes (e.g. MemoryOutputBuffer) don’t have either of these, so we have to resort to
if (output.getSize () != 0)
which seems super-strange, once you got used to isEmpty / isNotEmpty