It seems to me that the KnowPluginList class needs an isEmpty() and/or isValid() method…or have I missed an obvious alternative?
edit : ah scrap that, there’s no operator == in it…
I’ve actually worked passed a need for the new methods in my current code. But for others, and for my own future code, I think that isEmpty() and/or isValid() will be useful additions to the KnownPlugiList class.
Sure, but to be consistent with other JUCE code, the inclusion of isEmpty() and/or isValid() would be more direct and readable.