Getting Jack Audio to work on OSX (and Windows)?


#1

Hi all I’m working on a project where I would like to use Jack on OS X, but am having trouble getting it working. Could someone point me in the right direction?

Today I tried to adapt jpo’s code in this thread. I’ve modified the code to run with JUCE 5.1, but can’t get the libjack relay to start. Also, I’m unsure what the role of the libjack relay is, where it should be in my code, or if it even works on OS X. The place where my code is failing is that it appears to check if the libjack relay is running, and when it’s not it returns a null pointer instead of an AudioIODevice*.

Many thanks for any help. :slight_smile:


#2

Ok I think that relay_libjack.cpp are the wrapper for libjack functions, and you don’t “start” them, per se. They are made available to be used. Still, if anyone has experience getting this to work I’d really appreciate the help. :slight_smile:


#3

I’ve not tried this, but have you installed the JACK server software?


#4

Hi thanks for your reply. I made it past the problem I was dealing with, which was I was looking for a .so library when I should have been looking for a .dylib. I’m not to the finish line yet, but when I get there I’ll post my experiences and code for future folks. :slight_smile: