Graphic AU/VSTs in Audacity on Mac OS X


#1

Just wondering if anyone else has run into this problem lately. On the Mac OS X version of Audacity, when I load the demo JUCE plugin as either a VST or an AU, there appears to be a modality issue. When you click the plug-in window, you get a system beep and you can’t edit anything on the control. The plugin does however respond to mouse move events as you can see the controls being highlighted as the mouse moves over them. I’m not sure that there is a fix in JUCE for this–I think it’s a problem with Audacity.

This appears to not be an issue for the Windows version of Audacity though and the controls are editable.


#2

Not an issue that I’ve heard about - which version of juce is this?


#3

Well, I compiled Juce 1.51 from the zip and used the latest Audacity 1.3.12-beta on Mac OS X 10.6 Snow Leopard and its exhibiting this problem. I tried to compile the latest from the tip of the GIT, but I’m getting:

src/containers/…/core/juce_Atomic.h:234: error: no matching function for call to ‘OSAtomicAdd64Barrier(int, int64_t*&)’

#if JUCE_ATOMICS_MAC
return sizeof (Type) == 4 ? castFrom32Bit ((int32) OSAtomicAdd32Barrier (0, (int32_t*) &value))
: castFrom64Bit ((int64) OSAtomicAdd64Barrier (0, (int64_t*) &value));

Compiling:
JuceDemoPlugin, 10.5 SDK, i386 Release, or
JuceDemoPlugin, 10.6 SDK, i386 Release

By the way, the JUCE plug-ins do not have this issue in other software…GarageBand, etc.


#4

Thanks, I’ll check out that build error. Not sure what to suggest about the audacity thing, it does kind of sound like they’re doing something strange in their hosting.


#5

I just tried my plugins in Audacity, and found the same bug. Other plugins based around VSTGUI seemed to work fine. This isn’t a high priority to get working, and it is probably an Audacity bug, but I just thought I would mention it.

Sean Costello


#6

Has anyone tried Juce 2.0.x plugins in Audacity? I had another bug report about my plugins in Audacity today, and I just thought I’d see if any of the more recent code changes fix this issue. Again, this is not a high priority issue - just thought I’d ask.

Sean Costello


#7

Yep, this issue also happens with our Juce 2.0.x plugins as well as with the Juce Demo Plugin. (using Audacity 1.3.10-beta on OS X 10.8.2)


#8

Just discovered I’ve got the same issue. Did anyone figure out whether there was an easy fix?
cheers! J.


#9

FYI, I just tried and the issue is solved using Audacity 2.1.1 and Juce 3.2