Help Getting Jucer Working on ArchLinux Please


#1

First I downloaded the Intojucer file from this website and unzipped it but when trying to run it in bash, I gett errors like cannot execute command. I tried for hours to get the AUR version running wihtout success (with yaourt and from cli)  so instead dowloaded and inflated the tarball from git and ran make (no su) in the Linux directory with a makefile and it gave birth to the Introjucer binary  - woohoo!

Its alive! I can exec Introjucer and the lovely gui windows appears.  I can  "create new project" and browse the code however, if i start a new GUI project and right click on the file browser (left pane) and click "Add New GUI component" ... nada, zilch, nothing.

No errors appear in the terminal from which I ran Introjucer.

Any help greatly appreciated!

Many thanks!


#2

Hi soh, I have the Introjucer working on Ubuntu and we have compiled official packages for it here:

https://launchpad.net/~fabian+roli/+archive/ubuntu/juce

Is there a way for you in Arch to install .deb packages? Which version of ArchLinux are you on? 

 


#3

Hi Fabian

Thanks for the quick reply!

Not sure about deb packages in arch but much more fun compiling it from source anyway :)

I am using the latest version of arch (kernal, core, libraries all updated a few hours ago).

I am just now trying to install it with yaourt from the juce-git package in the Arch User Repository (AUR). I tried this before but it complained about CRLF characters in PKGBUILD so I have now edited it and seeing how it goes.

Latest:

Linking the Introjucer
PKGLD line 30...
cd/tmp/yaourt-tmp-sa/aur-juce-git/src/juce/extras/Demo/Builds/Linux/:  No such file or directory

Editing out the demos from PKGBLD and retrying :)

sed: -expression  #1   char 2@ unterminated 's' command
find: standard output
find: write error

 

Many thanks!

Sohail


#4

got it made and installed source from git repos.

when I launch /usr/bin/Introjucer, I can click create new GUI application which brings up the window to choose project name etc but clickig create does absolutely nothing

some progress at least :)


#5

@ soh - this just a thought but have you read the sticky post at the top of the linux forum that lists the bulid dependencies - perhaps you were able to build but are missing something needed to run the binary