How to change compiler in Introjucer?


#1

Hi everyone,

Due to Cryptopp libraries incompatibility, I cannot use LLVM GCC 4.2, this is, com.apple.compilers.llvmgcc42 compiler.
I must use Apple LLVM Compiler 3.1 (com.apple.compilers.llvm.clang.1_0.compiler) (a pity).

My question is, how can I parametrize Introjucer so that I can change compilers?

Thank you as usual,

Gabriel


#2

I’m pretty sure newer versions of the Introjucer default to Apple LLVM Compiler 3.1.


#3

Most probably possible using the ‘Xcode custom flags’ field, in Introjucer.

I use that to set many setting like :
ARCHS = “ppc i386 x86_64” ,VALID_ARCHS=“ppc i386 x86_64” ,MACOSX_DEPLOYMENT_TARGET_x86_64 = 10.6 ,MACOSX_DEPLOYMENT_TARGET_i386 = 10.5 ,SDKROOT_x86_64 = /Developer/SDKs/MacOSX10.6.sdk ,SDKROOT_ppc = /Developer/SDKs/MacOSX10.5.sdk ,GCC_VERSION_ppc = 4.0

You have to find the one for the compiler.

Salvator


#4

[quote=“Salvator”]Most probably possible using the ‘Xcode custom flags’ field, in Introjucer.

I use that to set many setting like :
ARCHS = “ppc i386 x86_64” ,VALID_ARCHS=“ppc i386 x86_64” ,MACOSX_DEPLOYMENT_TARGET_x86_64 = 10.6 ,MACOSX_DEPLOYMENT_TARGET_i386 = 10.5 ,SDKROOT_x86_64 = /Developer/SDKs/MacOSX10.6.sdk ,SDKROOT_ppc = /Developer/SDKs/MacOSX10.5.sdk ,GCC_VERSION_ppc = 4.0

You have to find the one for the compiler.

Salvator[/quote]

This is precisely the issue. There is not a setting to change it or, at least, I did not found it.


#5

The latest version of the Introjucer will set projects to use LLVM 3.1 by default now. No need to change any settings.


#6

OK cool, btw Jules, with the latest git, I’ve got a smal compile error with gcc 4.0
in juce_CPlusPlusCodeTokeniser.cpp

juce::CPlusPlusCodeTokeniser::getDefaultColourScheme()::Type' uses local type 'const juce::CPlusPlusCodeTokeniser::getDefaultColourScheme()::Type'
It seems it can’t parse

in

Hope this is possible to resolve. Maybe I need to switch to gcc4.2 too…

Salvator


#7

Thanks, I already fixed that, it fails in GCC 4.2 too.